On 08-08-17 13:27, Ian Molton wrote:
> On 08/08/17 12:19, Arend van Spriel wrote:
>>> #define brcmf_sdiod_func0_rb(sdiodev, addr, r) \
>>> - sdio_f0_readb((sdiodev)->func, (addr), (r))
>>> + sdio_f0_readb((sdiodev)->func, (addr), (r))
>> There is no reason to keep these any longer as these do not provide any
>> functionality over the core sdio function unless you consider the
>> sdiodev dereference.
> I tend to agree, although they're fairly readable anyway. I was trying
> to keep the changes small and incremental.
> I'll knock up a patch and see how it looks with them converted to the
> actual functions when I get back from hoiliday.
Enjoy the holiday. Glad to see I am not the only one checking email when
he is not supposed to work ;-)