Reza Arbab <ar...@linux.vnet.ibm.com> writes: > The flow of the main loop in parse_numa_properties() is overly > complicated. Simplify it to be less confusing and easier to read. > No functional change.
I think you're right, but it's not obvious from the diff. Please explain in more detail why the old and new code is equivalent. cheers