On Wed, 2016-11-30 at 19:21 +1100, Benjamin Herrenschmidt wrote:
> 
> There isn't one. The existing "opal-interrupts" from day one was a
> bit
> weird anyway, it's not a proper "interrupts" property to begin with,
> but it's unfixable now. Also I don't think there's a generic way to
> name interrupts either.
> 
> So for this specific case, just adding a new prop with a string-list
> matching 1:1 the entries in "opal-interrupts" is the most logical
> choice.

I spoke too soon... people have come up with an "interrupt-names"
property that matches a corresponding standard "interrupts" property.

The format is the same, a string-list with an entry per entry in
"interrupts".

So we have choices here... we could use the standard for both, making
OPAL generate both the old property and the new property "pair", then
make the code in linux look for the new one(s) and fallback, or we can
just add opal-interrupt-names, which is less churn but keeps it non-
standard.

I do have a soft-spot for going down the standard path even if it means
effectively duplicating the information between two properties. We'll
probably never be able to get rid of the old one, unless we backport
enough to make the new one mandatory for P9 in which case skiboot can
drop the "legacy" one on P9 and later.

Cheers,
Ben

Reply via email to