>>>>> "Enrico" == Enrico Weigelt, metux IT consult <i...@metux.net> writes:

 > Fix checkpatch warnings:
 >     WARNING: line over 80 characters
 >     #283: FILE: drivers/tty/serial/uartlite.c:283:
 >     +        ret = request_irq(port->irq, ulite_isr, IRQF_SHARED | 
 > IRQF_TRIGGER_RISING,

 >     WARNING: Missing a blank line after declarations
 >     #577: FILE: drivers/tty/serial/uartlite.c:577:
 >     +        struct earlycon_device *device = console->data;
 >     +        uart_console_write(&device->port, s, n, early_uartlite_putc);

 >     WARNING: line over 80 characters
 >     #590: FILE: drivers/tty/serial/uartlite.c:590:
 >     +OF_EARLYCON_DECLARE(uartlite_b, "xlnx,opb-uartlite-1.00.b", 
 > early_uartlite_setup);

 >     WARNING: line over 80 characters
 >     #591: FILE: drivers/tty/serial/uartlite.c:591:
 >     +OF_EARLYCON_DECLARE(uartlite_a, "xlnx,xps-uartlite-1.00.a", 
 > early_uartlite_setup);

Given that these are just a few characters more than 80 I don't really
think these changes improve readability.


 > Signed-off-by: Enrico Weigelt <i...@metux.net>
 > ---
 >  drivers/tty/serial/uartlite.c | 10 +++++++---
 >  1 file changed, 7 insertions(+), 3 deletions(-)

 > diff --git a/drivers/tty/serial/uartlite.c b/drivers/tty/serial/uartlite.c
 > index 6f79353..0140cec 100644
 > --- a/drivers/tty/serial/uartlite.c
 > +++ b/drivers/tty/serial/uartlite.c
 > @@ -280,7 +280,8 @@ static int ulite_startup(struct uart_port *port)
 >              return ret;
 >      }
 
 > -    ret = request_irq(port->irq, ulite_isr, IRQF_SHARED | 
 > IRQF_TRIGGER_RISING,
 > +    ret = request_irq(port->irq, ulite_isr,
 > +                      IRQF_SHARED | IRQF_TRIGGER_RISING,
 >                        "uartlite", port);
 >      if (ret)
 >              return ret;
 > @@ -574,6 +575,7 @@ static void early_uartlite_write(struct console *console,
 >                               const char *s, unsigned int n)
 >  {
 >      struct earlycon_device *device = console->data;
 > +
 >      uart_console_write(&device->port, s, n, early_uartlite_putc);

Unrelated change?

-- 
Bye, Peter Korsgaard

Reply via email to