Peter Zijlstra wrote:

...

> -#define lockdep_assert_irqs_disabled()       do {                    \
> -             WARN_ONCE(debug_locks && !current->lockdep_recursion && \
> -                       current->hardirqs_enabled,                    \
> -                       "IRQs not disabled as expected\n");           \
> -     } while (0)

...

> +#define lockdep_assert_irqs_disabled()                               \
> +do {                                                                 \
> +     WARN_ON_ONCE(debug_locks && this_cpu_read(hardirqs_enabled));   \
> +} while (0)

I think it would be nice to keep the "IRQs not disabled as expected"
message. It makes the lockdep splat much more readable.

This is similarly the case for the v3 lockdep preemption macros:

  https://lkml.kernel.org/r/20200630054452.3675847-5-a.darw...@linutronix.de

I did not add a message though to get in-sync with the IRQ macros above.

Thanks,

--
Ahmed S. Darwish
Linutronix GmbH

Reply via email to