"Aneesh Kumar K.V" <aneesh.ku...@linux.ibm.com> writes:
> Rename is_pkey_enabled() to is_pkey_masked() to better indicates that
> this check is to make sure the key is available for userspace usage.

I don't think the new name makes that any clearer. Unless you know that
"masked" means not "available for userspace".

It's also not clear if masked means 00 or 11.

Now that there's only one caller why not just fold it in, that way it
doesn't need a name at all.

> diff --git a/arch/powerpc/mm/book3s64/pkeys.c 
> b/arch/powerpc/mm/book3s64/pkeys.c
> index ca5fcb4bff32..70d760ade922 100644
> --- a/arch/powerpc/mm/book3s64/pkeys.c
> +++ b/arch/powerpc/mm/book3s64/pkeys.c
> @@ -206,18 +206,16 @@ static inline void write_uamor(u64 value)
>       mtspr(SPRN_UAMOR, value);
>  }
>  
> -static bool is_pkey_enabled(int pkey)
> +static bool is_pkey_masked(int pkey)
>  {
>       u64 uamor = read_uamor();
>       u64 pkey_bits = 0x3ul << pkeyshift(pkey);
>       u64 uamor_pkey_bits = (uamor & pkey_bits);
>  
>       /*
> -      * Both the bits in UAMOR corresponding to the key should be set or
> -      * reset.
> +      * Both the bits in UAMOR corresponding to the key should be set
>        */
> -     WARN_ON(uamor_pkey_bits && (uamor_pkey_bits != pkey_bits));
> -     return !!(uamor_pkey_bits);
> +     return (uamor_pkey_bits != pkey_bits);
>  }
>  
>  static inline void init_amr(int pkey, u8 init_bits)
> @@ -246,7 +244,7 @@ int __arch_set_user_pkey_access(struct task_struct *tsk, 
> int pkey,
>       u64 new_amr_bits = 0x0ul;
>       u64 new_iamr_bits = 0x0ul;
>  
> -     if (!is_pkey_enabled(pkey))
> +     if (is_pkey_masked(pkey))
>               return -EINVAL;

eg:
        u64 pkey_bits = 0x3ul << pkeyshift(pkey);

        if ((read_uamor() & pkey_bits) != pkey_bits)
                return -EINVAL;

>  
>       if (init_val & PKEY_DISABLE_EXECUTE) {


cheers

Reply via email to