On 7/2/26 04:57, [email protected] wrote:
> From: Wei Fang <[email protected]>
> 
> Since phylink only passes valid speed values to mac_link_up, the switch
> statement with its default fallback to SPEED_10 is unnecessary. Replace
> it with a direct call to PCR_PSPEED_VAL(). Also update PCR_PSPEED_VAL()
> to use FIELD_PREP() for proper field masking instead of an open-coded
> shift.
> 
> Signed-off-by: Wei Fang <[email protected]>

Reviewed-by: Maxime Chevallier <[email protected]>

Maxime


Reply via email to