On 2026/09/15 09:44 AM, Fuad Tabba wrote:
> There is no KVM_VCPU_RUN ioctl. The one that enters the guest is
> KVM_RUN, so refer to it by that name.
>
> Signed-off-by: Fuad Tabba <[email protected]>
> ---
> arch/powerpc/kvm/book3s_hv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/powerpc/kvm/book3s_hv.c b/arch/powerpc/kvm/book3s_hv.c
> index dbac3573b2c89..db090f4c5e95b 100644
> --- a/arch/powerpc/kvm/book3s_hv.c
> +++ b/arch/powerpc/kvm/book3s_hv.c
> @@ -269,7 +269,7 @@ static void kvmppc_fast_vcpu_kick_hv(struct kvm_vcpu
> *vcpu)
> * stolen time for a vcore when it is inactive, or for a vcpu
> * when it is in state RUNNING or NOTREADY. NOTREADY is a bit of
> * a misnomer; it means that the vcpu task is not executing in
> - * the KVM_VCPU_RUN ioctl, i.e. it is in userspace or elsewhere in
> + * the KVM_RUN ioctl, i.e. it is in userspace or elsewhere in
The erroneous name was introduced by commit c7b676709c16 ("KVM: PPC: Book3S HV:
Fix accounting of stolen time") and has sat untouched since. KVM_VCPU_RUN was
never a real ioctl; KVM_RUN is correct.
Reviewed-by: Amit Machhiwal <[email protected]>
Thanks,
Amit