On Tue, Feb 18, 2020 at 01:19:09PM -0800, Jacob Keller wrote:
> > +bool interface_tsinfo_valid(struct interface *iface)
> > +{
> > +   return iface->ts_info.valid ? true : false;
> > +}
> 
> Do you actually need the ternary here? shouldn't ts_info.valid get
> converted to true or false because we are returning a boolean?

Right.
 
> I don't think this is harmful and you may consider it improving
> readability though.

Yeah, that is the reason.  I like to have it spelled out in this case.

Thanks,
Richard



_______________________________________________
Linuxptp-devel mailing list
Linuxptp-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxptp-devel

Reply via email to