On 4/8/2023 5:42 PM, Erez wrote: > > I think I have it: > > + /* Run the callback on signaling messages if configured */ > + if (res == 0 && node->signaling_cb_ena && > (msg_type(*msg) == SIGNALING)) { > + res=2; > + } > > > - management_tlv_id(*msg) != ds_id) { > + res == 1 && management_tlv_id(*msg) != ds_id) { > > Erez :-)
Thanks for the effort. I started with a similar solution, but after seeing how unreadable it became - I decided to add a new variable to address the readability of this part of the code. I don't like abusing res to get fewer lines of code :) Thanks, Maciek _______________________________________________ Linuxptp-devel mailing list Linuxptp-devel@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/linuxptp-devel