The main focus of this submission is adding support for testing ADJ_OFFSET with
phc_ctl and querying the maximum supported ADJ_OFFSET adjustment that a device
is capable of. Some other minor cleanups are also included in the submission.

The patch the introduces support for querying the maximum offset supported by
ADJ_OFFSET depends on the following kernel patch series. Since the related patch
series in the kernel has not been accepted yet, submitting this patch as an RFC
for now.

Link: 
https://lore.kernel.org/netdev/20230523205440.326934-1-rrameshb...@nvidia.com/

Rahul Rameshbabu (5):
  Rename NSEC2SEC as NSEC_PER_SEC
  phc_ctl: Add phase command to support ADJ_OFFSET
  phc_ctl: Add maximum offset capability
  phc_ctl: Use pr_notice instead of pr_err for displaying adjusted
    frequency
  phc_ctl: Handle errors returned by various clockadj helpers

 missing.h      |  9 +++---
 phc_ctl.8      |  4 +++
 phc_ctl.c      | 77 +++++++++++++++++++++++++++++++++++++++-----------
 port.c         | 14 ++++-----
 port_private.h |  2 +-
 tc.c           |  6 ++--
 6 files changed, 80 insertions(+), 32 deletions(-)

-- 
2.38.5



_______________________________________________
Linuxptp-devel mailing list
Linuxptp-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/linuxptp-devel

Reply via email to