This is an automatic generated email to let you know that the following patch were queued:
Subject: media: media-entity.h: Fix documentation for media_create_intf_link Author: Ian Jamison <[email protected]> Date: Fri Apr 8 18:53:45 2022 +0100 The documentation comment was inserted between the return type and the function name. Reunite the lines. Signed-off-by: Ian Jamison <[email protected]> Fixes: db7ee32aa185 ("[media] media-device.h: Improve documentation and update it") Reviewed-by: Kieran Bingham <[email protected]> Reviewed-by: Laurent Pinchart <[email protected]> Signed-off-by: Sakari Ailus <[email protected]> Signed-off-by: Mauro Carvalho Chehab <[email protected]> include/media/media-entity.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- diff --git a/include/media/media-entity.h b/include/media/media-entity.h index 1d13b8939a11..a9a1c0ec5d1c 100644 --- a/include/media/media-entity.h +++ b/include/media/media-entity.h @@ -1030,7 +1030,6 @@ __must_check media_devnode_create(struct media_device *mdev, * removed. */ void media_devnode_remove(struct media_intf_devnode *devnode); -struct media_link * /** * media_create_intf_link() - creates a link between an entity and an interface @@ -1061,6 +1060,7 @@ struct media_link * * the interface and media_device_register_entity() should be called for the * interface that will be part of the link. */ +struct media_link * __must_check media_create_intf_link(struct media_entity *entity, struct media_interface *intf, u32 flags); _______________________________________________ linuxtv-commits mailing list [email protected] https://www.linuxtv.org/cgi-bin/mailman/listinfo/linuxtv-commits
