Hi all, I upgraded some pfSense on APU 

CPU Type
4 CPUs: 1 package(s) x 4 core(s) 
AES-NI CPU Crypto: Yes (active) 

 from 2.4.2-1 to 2.4.3-1

The first one via cmd-line (VPN - SSH).
It was installed with the default single disk ZFS option on SD, then set up 
(via GUI) to use  /
tmp and /var on RAM:

zroot/ROOT/default on / (zfs, local, noatime, nfsv4acls) 
The upgrade seemed to go on regularly, but the system did not came up for many 

Connected to the serial console, even after a power cicle, it showed (as copied 
from the 
console, sorry for the double chars):

NNoo  //bboooott//kkeerrnneell//kkeerrnneell

FFrreeeeBBSSDD//xx8866  bboooott

DDeeffaauulltt::  00::aadd((00,,aa))//bboooott//kkeerrnneell//kkeerrnneell


I thought it could be a problem related to /tmp or /var in RAM, but it I guess 
it wasn't 
because I reinstalled pfSense 2.4.2-1, reloaded the config I saved just before 
starting the 
previous upgrade so /tmp and /var should have been in RAM again. Then I 
upgraded via 
SSH (while connected to the serial console to monitor the process). Now the 
worked fine.

So, seen the problem I had on the first one upgrading via SSH I upgraded some 
similar APU  from 2.4.2-1 to 2.4.3-1 via GUI.
All of them are on SSD, some in UFS, some on ZFS, many of them with /tmp and 
/var in 
All but one (SSD, UFS, /tmp and /var in RAM) upgraded fine. The one that did 
not upgrade 
was in the same status and with the same message copied above. Again I 
2.4.2-1, reloaded the last config, upgraded via GUI and everything worked fine. 

Did someone have similar issues or have any clue abaout it?

pfSense mailing list
Support the project with Gold! https://pfsense.org/gold

Reply via email to