Exactly, displaying an 'ip' register which is not the instruction pointer is very unhelpful.
The existing register names are currently different on posix-vs-Darwin anyway, so there shouldn't be any harm in making the change now. I think it's "fioff" on Darwin. It uses different display names vs. the internal variable names. I agree that it would be nice to make it consistent everywhere. Personally I'm in favor of it matching the Intel names as closely as possible. I'm slightly puzzled by how many places in the codebase (re)define the register sets, it seems like making changes like this may not be straightforward. Richard Mitton [email protected] http://llvm-reviews.chandlerc.com/D1307 _______________________________________________ lldb-commits mailing list [email protected] http://lists.cs.uiuc.edu/mailman/listinfo/lldb-commits
