I would vote for a cleaner fix for the "%zu" stuff. Currently there is a block of code in each file that uses it:
#if defined(_MSC_VER) #define ZUFix "%d" #else #define ZUFix "%4zu" #endif This would be better fixed by casting any "size_t" to "uint64_t", or "ssize_t" to "int64_t" and using "PRI*64" the appropriate macros. This would make the changes more portable. On Oct 18, 2013, at 8:07 AM, Deepak Panickal <[email protected]> wrote: > Removed __func__ > > http://llvm-reviews.chandlerc.com/D1976 > > CHANGE SINCE LAST DIFF > http://llvm-reviews.chandlerc.com/D1976?vs=5029&id=5030#toc > > Files: > source/DataFormatters/FormatManager.cpp > source/Host/common/SocketAddress.cpp > source/Plugins/DynamicLoader/POSIX-DYLD/AuxVector.cpp > source/Plugins/DynamicLoader/POSIX-DYLD/DynamicLoaderPOSIXDYLD.cpp > source/Plugins/Process/gdb-remote/GDBRemoteCommunication.cpp > source/Plugins/Process/gdb-remote/GDBRemoteCommunicationClient.cpp > source/Plugins/Process/gdb-remote/GDBRemoteRegisterContext.cpp > source/Plugins/Process/gdb-remote/ProcessGDBRemote.cpp > source/Target/Process.cpp > tools/driver/ELWrapper.cpp > <D1976.2.patch>_______________________________________________ > lldb-commits mailing list > [email protected] > http://lists.cs.uiuc.edu/mailman/listinfo/lldb-commits _______________________________________________ lldb-commits mailing list [email protected] http://lists.cs.uiuc.edu/mailman/listinfo/lldb-commits
