labath added a comment.

In https://reviews.llvm.org/D40133#927655, @krytarowski wrote:

> I'm just thinking whether change code like `CoreRegset::PPC_VMX` to 
> `CoreRegset::PPC::VMX`. I'm planning to add `CoreRegset::X86_64::XSAVE` in 
> future.


That's an interesting idea, but I don't see how would that be possible -- enum 
values can't have nested names. I suppose we could fake that by making 
`CoreRegset` and `CoreRegset::X86_64` namespaces, but then the name of the enum 
type would have to be something different (`CoreRegset::Type`?).  I am not sure 
if that's worth the trouble.

I don't think we will have that many register sets, so it's probably fine to 
have flat namespaces for arch/regset combinations.


https://reviews.llvm.org/D40133



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
  • [Lldb-commits] ... Pavel Labath via Phabricator via lldb-commits
    • [Lldb-comm... Kamil Rytarowski via Phabricator via lldb-commits
    • [Lldb-comm... Alexandre Yukio Yamashita via Phabricator via lldb-commits
    • [Lldb-comm... Pavel Labath via Phabricator via lldb-commits
    • [Lldb-comm... Greg Clayton via Phabricator via lldb-commits
    • [Lldb-comm... Pavel Labath via Phabricator via lldb-commits
    • [Lldb-comm... Greg Clayton via Phabricator via lldb-commits
    • [Lldb-comm... Pavel Labath via Phabricator via lldb-commits
    • [Lldb-comm... Pavel Labath via Phabricator via lldb-commits
    • [Lldb-comm... Pavel Labath via Phabricator via lldb-commits

Reply via email to