aprantl added a comment.

In https://reviews.llvm.org/D48295#1136692, @apolyakov wrote:

> I don't completely understand what you mean. First of all, what do you mean 
> when talking about success_handlers? 'cause if you mean success_handler from 
> `Execute` function, then I should say that it doesn't have to set an error, 
> it might be any. Secondly, `status` in your example is a function, how can it 
> has a `takeError` method?


`status` is meant to be a `bool`. I think `success_handler` was a bad name. It 
should probably be called `action` or `command` something similar. It would be 
the actual implementation of the command, such as lambda that is assigned to 
`success_handler` in your patch.


https://reviews.llvm.org/D48295



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to