labath added a comment.

Wouldn't it be even better to actually expose the llvm class via some accessor 
or something? This way we could slowly migrate existing code by changing it to 
write to `stream.accessor()` instead of `stream` ? (I am not saying to do that 
now, but it opens up possibilities for the future.)

I also found it hard to deduce who is forwarding to whom from the member names. 
Maybe rename `m_forward_to` to `m_target` or something like that?


https://reviews.llvm.org/D50161



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to