It's an interesting idea, thanks! I don't object moving code around if there's a strong case for it, but I'd like to keep the fix small and simple for now, but it's worth considering if the current minidump loading path will need more flexibility.
On Thu, Aug 23, 2018 at 1:27 PM, Greg Clayton via Phabricator < revi...@reviews.llvm.org> wrote: > clayborg added a comment. > > In https://reviews.llvm.org/D51176#1211433, @jingham wrote: > > > The other option would be to move the code that populates the section > load list into the mini dump dynamic loader. That has the benefit of > keeping this consistent with the other process plugins, but OTOH is just > moving code around... > > > Yes the dynamic loader plug-ins aren't hard to write and the code already > exists in the ProcessMinidump. Then you would request the plug-in by name > instead of passing a nullptr as the name in ProcessMinidump:: > GetDynamicLoader(). > > > Repository: > rLLDB LLDB > > https://reviews.llvm.org/D51176 > > > >
_______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits