labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
Sounds good. If this were a more permanent interface, I'd argue that the function should be called `TakeStream` (in analogy with `llvm::Expected::takeError`), but for a temporary thing that does not matter... ================ Comment at: lldb/source/Host/common/File.cpp:166-167 +FILE *File::TakeStreamAndClear() { + GetStream(); + FILE *stream = m_stream; + m_stream = NULL; ---------------- `FILE *stream = GetStream()` ? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68160/new/ https://reviews.llvm.org/D68160 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits