labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
LG, though I'm not sure whether using `using namespace llvm` is such a good idea. There's a fair number of classes with identical names in llvm and lldb_private namespaces. As we start using more of llvm, we will start hitting conflicts. E.g., I've had to handle a bunch of conflicts when I made lldb_private::DataExtractor convertible to llvm::DataExtractor (which made the second name visible nearly everywhere). For this particular case a namespace alias (`namespace json = llvm::json`) might be a better option. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D68301/new/ https://reviews.llvm.org/D68301 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits