MaskRay created this revision.
MaskRay added reviewers: JDevlieghere, jingham, labath.
Herald added subscribers: lldb-commits, aheejin.
Herald added a project: LLDB.
MaskRay added a comment.

https://github.com/google/llvm-premerge-checks/issues/142 This should suppress 
the annoying `clang-tidy linux` diagnostics in `Diff Detail - Build Status`.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D75810

Files:
  lldb/.clang-tidy


Index: lldb/.clang-tidy
===================================================================
--- /dev/null
+++ lldb/.clang-tidy
@@ -0,0 +1,21 @@
+# Almost identical to the top-level .clang-tidy, except that
+# - FunctionCase uses CamelCase
+# - {Member,Parameter,Variable}Case use lower_case
+Checks: 
'-*,clang-diagnostic-*,llvm-*,misc-*,-misc-unused-parameters,-misc-non-private-member-variables-in-classes,readability-identifier-naming'
+CheckOptions:
+  - key:             readability-identifier-naming.ClassCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.EnumCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.FunctionCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.MemberCase
+    value:           lower_case
+  - key:             readability-identifier-naming.ParameterCase
+    value:           lower_case
+  - key:             readability-identifier-naming.UnionCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.VariableCase
+    value:           lower_case
+  - key:             readability-identifier-naming.IgnoreMainLikeFunctions
+    value:           1


Index: lldb/.clang-tidy
===================================================================
--- /dev/null
+++ lldb/.clang-tidy
@@ -0,0 +1,21 @@
+# Almost identical to the top-level .clang-tidy, except that
+# - FunctionCase uses CamelCase
+# - {Member,Parameter,Variable}Case use lower_case
+Checks: '-*,clang-diagnostic-*,llvm-*,misc-*,-misc-unused-parameters,-misc-non-private-member-variables-in-classes,readability-identifier-naming'
+CheckOptions:
+  - key:             readability-identifier-naming.ClassCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.EnumCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.FunctionCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.MemberCase
+    value:           lower_case
+  - key:             readability-identifier-naming.ParameterCase
+    value:           lower_case
+  - key:             readability-identifier-naming.UnionCase
+    value:           CamelCase
+  - key:             readability-identifier-naming.VariableCase
+    value:           lower_case
+  - key:             readability-identifier-naming.IgnoreMainLikeFunctions
+    value:           1
_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to