jingham accepted this revision.
jingham added a comment.

If you have --force, then the address range is informational, in which case 
having the full command would be more confusing than anything.  So this is 
fine, thanks for adding it.

I thought briefly about whether we should also add a setting for this.  But if 
it is something that you come across often you can just re-alias `di` to 
`disassemble --force`.  I used to think we needed to always provide global 
settings for this sort of behavior, but if the setting just controls the 
behavior of one command, I'm beginning to think using aliases is better than 
adding more and more stuff to the settings.

I agree you want to print out the range.  Many of the times you get huge 
functions, they aren't actually huge, they just look that way because we're 
just missing the subsequent symbols.  So the user might be disassembling 
something they know is a small function, and we need to give them some clue to 
why we think that's not so.

This looks fine to me.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D79789/new/

https://reviews.llvm.org/D79789



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to