rnk added inline comments.

================
Comment at: lldb/source/Plugins/SymbolFile/NativePDB/PdbAstBuilder.cpp:1124
+  // Inlinee is the id index to the function id record that is inlined.
+  PdbTypeSymId func_id(inline_site.Inlinee, true);
+  // Look up the function decl by the id index to see if we have created a
----------------
inline_site is unused from here on in. Really, this function gets or creates a 
FunctionDecl from an LF_FUNC_ID record. Inline sites happen to point to one of 
those. Instead of naming this `GetOrCreateInlinedFunctionDecl`, could you name 
this `GetOrCreateFunctionDeclFromId` and restructure it accordingly? I think 
that will be more useful in the future if and when we have to make decls from 
other ids.

I believe S_*PROC32 records do not reference these records, so I don't think 
there is a way to share the codepaths.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D121967/new/

https://reviews.llvm.org/D121967

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to