mib added inline comments.
================ Comment at: lldb/test/API/macosx/queues/TestQueues.py:204-206 + process_info = lldbutil.run_to_name_breakpoint(self, "stopper", only_one_thread=False) + main_thread = process_info[2] + queue_breakpoint = process_info[3] ---------------- Why not do it this way ? Takes less space and it's easier to read (for people who don't know what `process_info[2]` and `process_info[3]` refers to) ================ Comment at: lldb/test/API/macosx/queues/TestQueues.py:318 + main_thread = threads[0] self.inferior_process = process ---------------- Do you still need this ? ================ Comment at: lldb/test/API/macosx/queues/TestQueues.py:389-391 + process_info = lldbutil.run_to_name_breakpoint(self, "stopper", only_one_thread=False) + main_thread = process_info[2] + queue_breakpoint = process_info[3] ---------------- ditto Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131605/new/ https://reviews.llvm.org/D131605 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits