clayborg added inline comments.
================ Comment at: lldb/bindings/interface/SBTarget.i:969 + lldb::SBStructuredData GetSourceMap(); + ---------------- Do we want to actually have something more like this: ``` lldb::SBStructuredData GetSetting(const char *setting); ``` That allows us to get any setting as structured data? We have a lot of settings and I would rather not have an API for each one of these added to the public API as we need them. Eventually we could also have: ``` void SetSetting(lldb::SBStructuredData &data); ``` This would allow the output to contain multiple settings if needed. Hopefully the output would be in the format of: ``` { "target.source-map": [["<orig-path>", "<replace-path>"], ...] } ``` This would allow us to export all settings, and then import them. ================ Comment at: lldb/source/Target/PathMappingList.cpp:138 + llvm::json::Object entry; + entry.try_emplace("first", pair.first.GetStringRef().str()); + entry.try_emplace("second", pair.second.GetStringRef().str()); ---------------- jingham wrote: > Can we call these something more instructive than "first" and "second"? > These are the "original" path and the "substitution" path, maybe those would > be good keys? We can either do this as a key/value pair thing or just as a array of array path pairs in JSON? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D133038/new/ https://reviews.llvm.org/D133038 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits