https://bugs.llvm.org/show_bug.cgi?id=40014

            Bug ID: 40014
           Summary: __lzcnt32() should be __lzcnt() in lzcntintrin.h
           Product: clang
           Version: 7.0
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: normal
          Priority: P
         Component: Headers
          Assignee: unassignedclangb...@nondot.org
          Reporter: cerick...@curedev.com
                CC: craig.top...@gmail.com, llvm-bugs@lists.llvm.org,
                    richard-l...@metafoo.co.uk

In the lzcntintrin.h, the 32-bit version of lzcnt should be named __lzcnt(),
not __lzcnt32().

This causes linker errors when compiling with ms compatibility because the
correct prototype is in intrin.h:

unsigned int __lzcnt(unsigned int);

See https://docs.microsoft.com/en-us/cpp/intrinsics/lzcnt16-lzcnt-lzcnt64 for
reference.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
llvm-bugs mailing list
llvm-bugs@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-bugs

Reply via email to