> -----Original Message-----
> From: lng-odp [mailto:lng-odp-boun...@lists.linaro.org] On Behalf Of EXT
> Maxim Uvarov
> Sent: Thursday, December 10, 2015 1:45 PM
> To: lng-odp@lists.linaro.org
> Subject: [lng-odp] [API-NEXT PATCH] api: pktio link state
> 
> Signed-off-by: Maxim Uvarov <maxim.uva...@linaro.org>
> ---
>  include/odp/api/packet_io.h | 11 +++++++++++
>  1 file changed, 11 insertions(+)
> 
> diff --git a/include/odp/api/packet_io.h b/include/odp/api/packet_io.h
> index 443841e..f970ad7 100644
> --- a/include/odp/api/packet_io.h
> +++ b/include/odp/api/packet_io.h
> @@ -673,6 +673,17 @@ void
> odp_pktio_output_queue_param_init(odp_pktio_output_queue_param_t *param);
>  void odp_pktio_print(odp_pktio_t pktio);
> 
>  /**
> + * Determine pktio link is up or down for a packet IO interface.
> + *
> + * @param[in] pktio Packet IO handle.

[in] is not needed. All params are input by default. We highlight output params 
with [out].

> + *
> + * @retval  1 link is up
> + * @retval  0 link is down
> + * @retval <0 on failure
> +*/
> +int odp_pktio_link_state(odp_pktio_t pktio);

int odp_pktio_link_status(odp_pktio_t pktio);

Status would be better name for the call. RFCs use variable name IfOperStatus. 
RFC2863 defines additional states: notPresent, lowerLayerDown, which refine 
down state.

DPDK names this link_status (1 up, 0 down) in struct rte_eth_link.



-Petri


> +
> +/**
>   * @}
>   */
> 
> --
> 1.9.1
> 
> _______________________________________________
> lng-odp mailing list
> lng-odp@lists.linaro.org
> https://lists.linaro.org/mailman/listinfo/lng-odp
_______________________________________________
lng-odp mailing list
lng-odp@lists.linaro.org
https://lists.linaro.org/mailman/listinfo/lng-odp

Reply via email to