Hi,
I see that newer ubuntu has an updated version of DPDK. How can I build/run
ODP with this DPDK in ubuntu? For me it fails at configure step.
*Steps:*
 1)Install dpdk-dev, libdpdk-dev, dpdk
 2) ./configure --prefix=/root/odp/build
--with-dpdk-path=/usr/share/dpdk/arm64-armv8a-linuxapp-gcc/

*I am getting an error in configure step:*

configure: Using shared DPDK library found at
/usr/share/dpdk/arm64-armv8a-linuxapp-gcc//lib
checking rte_config.h usability... no
checking rte_config.h presence... no
checking for rte_config.h... no
checking for rte_eal_init in -ldpdk ... yes
configure: error: in `/root/odp':
configure: error: can't find DPDK
See `config.log' for more details


*Output from config.log file:*

configure:20358: Using shared DPDK library found at
/usr/share/dpdk/arm64-armv8a-linuxapp-gcc//lib
configure:20374: checking rte_config.h usability
configure:20374: gcc -c -g -O2 -pthread -isystem
/usr/share/dpdk/arm64-armv8a-linuxapp-gcc//include/dpdk  conftest.c >&5
conftest.c:107:10: fatal error: rte_config.h: No such file or directory
 #include <rte_config.h>
          ^~~~~~~~~~~~~~
compilation terminated.
configure:20374: $? = 1


*The rte_config.h file is foud at:*

root@cavium:~/odp# locate rte_config.h
/usr/include/aarch64-linux-gnu/dpdk/rte_config.h
/usr/share/dpdk/arm64-armv8a-linuxapp-gcc/include/rte_config.h


It is ubuntu 18.04, DPDK 17.11 and AARCH64 system.

Thanks,
P Gyanesh Kumar Patra

Reply via email to