Hi! In the current implementation, the RollingFileAppender always names backup files to "<filename>.1", "<filename>.2" etc.
It would be great, if developers could add their own naming convention. This could be done using different ways (I think): a) The developer sets a naming pattern String as a parameter to the RollingFileAppender, which defines the filename (similar to PatternLayout), e.g. "%f.%d.%n", where %f = filename, %d = date, %n = backupIndex b) The developer implements an interface, which provides a single method to generate a filename for a backup file: public interface BackupFilenameResolver { public String getFilename( int backupIndex ); } An implementing class name of this interface may then be set as a parameter to the RollingFileAppender (similar to how ObjectRenderers are currently configured) I would prefer soultion (b), since it is more flexible. Greetings from Germany, Thomas -- To unsubscribe, e-mail: <mailto:[EMAIL PROTECTED]> For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>