On Tue, Jul 8, 2014 at 10:47 AM, Ralph Goers <[email protected]> wrote:
> > On Jul 8, 2014, at 7:32 AM, Gary Gregory <[email protected]> wrote: > > On Mon, Jul 7, 2014 at 1:44 PM, Ralph Goers <[email protected]> > wrote: > >> Well, If there is only one Filter then it would just be declared. If >> there is more than one then it should be: >> >> <Filters> >> <Filter>…</Filter> >> <Filter>…</Filter> >> <Filters> >> >> Even in this case since there is only the CompositeFilter (which contains >> the other Filters) there should only be one Filter and it should be >> declared as PluginElement(“Filter”). The only place >> PluginElement(“Fitlers”) should be used is on CompositeFilter. >> FileAppender would be wrong to have “Filters” specified. >> > > Double checking: > > - The PluginElement on CompositeFilter typed as Filter[] should be named > "Filters" (plural). This is the only Filter[] PluginElement. This does not > need fixing. > - All PluginElement usage typed as Filter should be named "Filter" > (singular). This means fixing some call sites. > > > call sites? Do you mean tests? > I mean: - methods annotated with @PluginElemen("Filters") that should be renamed to @PluginElemen("Filter") - test config files Gary > > Ralph > > > -- E-Mail: [email protected] | [email protected] Java Persistence with Hibernate, Second Edition <http://www.manning.com/bauer3/> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/> Spring Batch in Action <http://www.manning.com/templier/> Blog: http://garygregory.wordpress.com Home: http://garygregory.com/ Tweet! http://twitter.com/GaryGregory
