You will have you run your checkout/update with the -P flag to prune any
empty directories, as there is no way of completely deleting the
directory.  The other option is to delete the repository and check it back
in again.


On Mon, 18 Jun 2001, Simon Wistow wrote:

> I admin the project 'Gravel' (
> When I was adding a directory 'libswfparse' to my CVS repository I
> accidentall added the folder again as a subdirectory (so that as well as
> /libswfparse I also have /libswfparse/libswfparse). I've tried to remove
> the extraneous subdirectory but can't seem to do it.
> % cvs remove libswfparse
> either
> o claims to have removed it and then doesn't
> o removes everything in /libswfparse/ but keeps everything in
> /libswfparse/libswfparse/
> o doesn't do anything (often claiming the directory doesn't exist)
> I've tried manually munging CVS/Entries to include the files in the
> subdirectory which didn't appear to be there before but then I get the
> message
> cvs server: Examining libswfparse
> cvs server: Up-to-date check failed for `libswfparse/Makefile'
> [snip, for every single file]
> cvs server: Up-to-date check failed for `libswfparse/swf_types.h'
> cvs server: Up-to-date check failed for `libswfparse/todo'
> when I try and do a commit.
> any idea how I can fix this. I'll admit to being a complete CVS newbie.
> --
> simon wistow            wireless systems coder
>  only second toughest

Reply via email to