rm is for a remote LPD host and rp is for a spoolname on this host. As you have said these printers don't use LPD, this is not what you want. The raw has no business in your printcap as it is a queue name and port 9100 does not need port designations. You want the following:
xena :force_localhost@ :lp=xenaprint.engin.umich.edu%9100 :sd=/var/spool/lpd/xena ...this should do the trick, plus whatever printcap options you're interested in. ---- _ _ _ _ ___ _ _ _ |Y#| | | |\/| | \ |\ | | | Ryan Novosielski - Jr. UNIX Systems Admin |$&| |__| | | |__/ | \| _| | [EMAIL PROTECTED] - 732/235.4473 (5-4473) \__/ Univ. of Med. and Dent. | IST/ACS - Robert Wood Johnson MS - S-B11 > -----Original Message----- > From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of > James Thomas Klaas > Sent: Monday, October 01, 2001 11:16 AM > To: [EMAIL PROTECTED] > Subject: LPRng: problems printing to HPJetDirect > > > I am attempting to set up a print queue to print to a JetDirect printer > and I am having some problems setting up the queue. First off, we are not > running any lpd servers on our machines. This reduces our security > profile and makes it easier to control clients. > > I have come up with a couple of printcap entries to try: > > xena:force_localhost@:rm=xenaprint.engin.umich.edu%9100:rp=raw > > -- This fails with an error: > > Printer: xena is [EMAIL PROTECTED]%9100 > Printer '[EMAIL PROTECTED]%9100' - cannot open connection - > bad or missing hostname > Make sure LPD server is running on the server > > So it obviously doesn't recognize the format host%port for rm. > > Second: > > xena:lp=xenaprint.engin.umich.edu%9100 > > -- This fails with: > > Printer 'xena@localhost' - cannot open connection - Connection refused > Make sure LPD server is running on the server > > This fails because an lp=host%port only works if an lpd is running > locally. Is there any way to get this to work? > > James Klaas (734)615-0364 > CAEN Systems Group > IST 5113 > > > > ------------------------------------------------------------------ > ----------- > YOU MUST BE A LIST MEMBER IN ORDER TO POST TO THE LPRNG MAILING LIST > The address you post from MUST be your subscription address > > If you need help, send email to [EMAIL PROTECTED] (or lprng-requests > or lprng-digest-requests) with the word 'help' in the body. For > the impatient, > to subscribe to a list with name LIST, send mail to [EMAIL PROTECTED] > with: | example: > subscribe LIST <mailaddr> | subscribe lprng-digest [EMAIL PROTECTED] > unsubscribe LIST <mailaddr> | unsubscribe lprng [EMAIL PROTECTED] > > If you have major problems, send email to [EMAIL PROTECTED] > with the word > LPRNGLIST in the SUBJECT line. > ------------------------------------------------------------------ > ----------- > ----------------------------------------------------------------------------- YOU MUST BE A LIST MEMBER IN ORDER TO POST TO THE LPRNG MAILING LIST The address you post from MUST be your subscription address If you need help, send email to [EMAIL PROTECTED] (or lprng-requests or lprng-digest-requests) with the word 'help' in the body. For the impatient, to subscribe to a list with name LIST, send mail to [EMAIL PROTECTED] with: | example: subscribe LIST <mailaddr> | subscribe lprng-digest [EMAIL PROTECTED] unsubscribe LIST <mailaddr> | unsubscribe lprng [EMAIL PROTECTED] If you have major problems, send email to [EMAIL PROTECTED] with the word LPRNGLIST in the SUBJECT line. -----------------------------------------------------------------------------
