Hi Gunter and all,

draft-ietf-lsr-flood-reduction-arch is a WG document that has been
discussed multiple times in meeting sessions; the WG approves allocating
the following code points:
The IS-IS registry - IS-IS Sub-TLVs for IS-IS Router CAPABILITY TLV
The OSPF registry - OSPF Router Information (RI) TLVs

draft-ietf-lsr-distoptflood is requesting a code point from the "IGP
Algorithm Type For Computing Flooding Topology" registry, and the WG
approves the request. However, the registry is missing experts. This needs
to be fixed before the requested code point can be allocated.

Thanks,
Yingzhen

On Mon, Mar 30, 2026 at 11:16 PM Gunter van de Velde (Nokia) <
[email protected]> wrote:

> Hi Acee, All,
>
> First thanks to Les for the datapoints and input regarding the request for
> code points under the IS-IS Sub-TLVs for IS-IS Router CAPABILITY TLV with
> "Expert Review"
>
> For "The OSPF registry - OSPF Router Information (RI) TLVs is "IETF
> Review"" there is the path of RFC7120 early allocation assuming the
> conditions outlined in section 2 are met.
> In general that boils down to the following:
> 1) The code point specifications  "must be adequately described"
> 2) The specifications must be considered stable
> 3) WG  chairs and AD judge judge that there is sufficient community
> interest
>
> Assuming (1) and (2) are confirmed, then similar as with the ISIS request
> the chairs provide indication (presumably w Acee abstaining as a co-author)
> of community interest to IANA with an early code point request, and the
> allocation processing will take place.
>
> G/
>
>
>
> ------------------------------
> *From:* Les Ginsberg (ginsberg) <[email protected]>
> *Sent:* Saturday, March 28, 2026 3:13 AM
> *To:* Acee Lindem <[email protected]>; Tony Przygienda <
> [email protected]>; Gunter van de Velde (Nokia) <
> [email protected]>; lsr <[email protected]>
> *Cc:* lsr-chairs <[email protected]>; Hannes Gredler ([email protected])
> <[email protected]>
> *Subject:* RE: [Lsr] Re: Request for temporary assignements of
> code4points
>
>
> CAUTION: This is an external email. Please be very careful when clicking
> links or opening attachments. See the URL nok.it/ext for additional
> information.
>
>
>
> Sooo...without trying to be overly formal...
>
> https://www.rfc-editor.org/rfc/rfc7370.html#section-4 applies...
>
> Summarizing
>
> 1)We need a request from the draft authors.
> Let 's consider that requirement met.
>
> 2)We need an indication from the WG chairs that
> "there is consensus within the Working Group to make the allocation at
> this time."
>
> I think once the chairs provide that indication (presumably w Acee
> abstaining as a co-author) then the Designated Experts (Hannes, Chris, and
> myself)
> can proceed.
>
>    Les
>
> >-----Original Message-----
> >From: Acee Lindem <[email protected]>
> >Sent: Thursday, March 26, 2026 10:32 AM
> >To: Tony Przygienda <[email protected]>; Gunter van de Velde (Nokia)
> ><[email protected]>; lsr <[email protected]>
> >Cc: lsr-chairs <[email protected]>
> >Subject: [Lsr] Re: Request for temporary assignements of code4points
> >
> >+Gunter and LSR list. I'm a co-author so I won't comment.
> >
> >The IS-IS registry - IS-IS Sub-TLVs for IS-IS Router CAPABILITY TLV is
> "Expert
> >Review"
> >The OSPF registry - OSPF Router Information (RI) TLVs is "IETF Review"
> >
> >Thanks,
> >Acee
> >
> >> On Mar 26, 2026, at 5:16 AM, Tony Przygienda <[email protected]>
> >wrote:
> >>
> >> Hey, as indicated in my preso we are at interoping flood reduction and
> need
> >codepoints by now
> >>
> >>
> https://datatracker.ietf.org/doc/draft-ietf-lsr-flood-reduction-arch/01/
> >>
> >> needs
> >>
> >> sub-TLV within a Router Capability TLV (242) defined in [RFC7981]
> >>
> >>
> >> and for OSPF
> >>
> >> The Flood Reduction Algorithm TLV is advertised within a OSPFv2
> >> Router Information (RI) Opaque LSA or OSPFv3 Router Information LSA
> >> as defined in [RFC7770]
> >>
> >>
> >>
> >> We will also need an algorithm value for
> >>
> >> https://datatracker.ietf.org/doc/html/draft-ietf-lsr-distoptflood-13
> >>
> >> IANA is requested to allocate a TBD value in 1-127 range with
> description of
> >"Modified MANET Reduction" further referring to
> >> this document as specification in the "IGP Algorithm Type For Computing
> >Flooding Topology" registry.
> >>
> >>
> >> whereas personally I still think having a separate registry for
> "_Distributed_
> >IGP Algorithm Type For Computing Flooding Topology" would be better
> >>
> >>
> >>
> >> Could you please issue the according calls ?
> >>
> >>
> >> thanks
> >>
> >>
> >> --- tony
> >>
> >>
> >>
> >
> >_______________________________________________
> >Lsr mailing list -- [email protected]
> >To unsubscribe send an email to [email protected]
>
_______________________________________________
Lsr mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to