Hello,
I have the LWIP stack 2.0.3 in combination with FREERTOS 9.0 running on a
STM32H743.
When only one tcp (netconn server) connection is active the data
transmission perform very well and no errors occur.
But when a second tcp-connection connects and transmits data simultaneously
to the first, i get PCB mismatches:

tcp_input: no PCB match found, resetting.
tcp_rst: seqno 1316683776 ackno 285205344.
tcp_input: no PCB match found, resetting.
tcp_rst: seqno 1820393472 ackno 2550260832.
tcp_input: no PCB match found, resetting.
tcp_rst: seqno 2642739200 ackno 1409541216.
.....


I run a MBTCP server and a webserver on the device.
On wireshark i see the resets and retransmits.

Where can it come from?
If you need more information i will reply.

Here are my stats:
link = {xmit = 0, recv = 0, fw = 0, drop = 0, chkerr = 0, lenerr = 0, memerr
= 0, rterr = 0, proterr = 0, opterr = 0, err = 0, cachehit = 0},
etharp = {xmit = 10, recv = 1309, fw = 0, drop = 51, chkerr = 0, lenerr = 0,
memerr = 0, rterr = 0, proterr = 51, opterr = 0, err = 0, cachehit = 13975},
ip_frag = {xmit = 0, recv = 0, fw = 0, drop = 0, chkerr = 0, lenerr = 0,
memerr = 0, rterr = 0, proterr = 0, opterr = 0, err = 0, cachehit = 0},
ip = {xmit = 13977, recv = 14816, fw = 0, drop = 38, chkerr = 0, lenerr =
15, memerr = 0, rterr = 0, proterr = 0, opterr = 0, err = 0, cachehit = 0},
icmp = {xmit = 0, recv = 0, fw = 0, drop = 0, chkerr = 0, lenerr = 0, memerr
= 0, rterr = 0, proterr = 0, opterr = 0, err = 0, cachehit = 0},
udp = {xmit = 0, recv = 38, fw = 0, drop = 0, chkerr = 0, lenerr = 0, memerr
= 0, rterr = 0, proterr = 0, opterr = 0, err = 0, cachehit = 0},
tcp = {xmit = 13176, recv = 14740, fw = 0, drop = 60, chkerr = 0, lenerr =
0, memerr = 0, rterr = 0, proterr = 60, opterr = 0, err = 0, cachehit =
13742},
sys = {sem = {used = 2, max = 4, err = 0},
mutex = {used = 2, max = 2, err = 0},
mbox = {used = 3, max = 5, err = 0} 



--
Sent from: http://lwip.100.n7.nabble.com/lwip-users-f3.html

_______________________________________________
lwip-users mailing list
lwip-users@nongnu.org
https://lists.nongnu.org/mailman/listinfo/lwip-users

Reply via email to