I have also a webserver running.
I can see that the used pcb mem goes back if the Client (not the MCU) closes
the connection (modbus),
but if the server (the MCU) closes the connection the used pcbs doesn't go
back (webserver).
If i have only the mobus connection in use the maximum of the pcbs is only 2
(similar to the real connections).

Strange is also that the destination port of the received message seems to
be wrong.
I debugged the tcp_input function a bit and i get a wrong destination Port
in the tcphdr struct:

tcphdr error (mb):
src     u16_t   7378    
dest    u16_t   62977   
seqno   u32_t   752975085       
ackno   u32_t   2805334016      
_hdrlen_rsvd_flags      u16_t   6224    
wnd     u16_t   28151   
chksum  u16_t   48586   
urgp    u16_t   0       

tcphdr error (mb):
src     u16_t   8658    
dest    u16_t   62977   
seqno   u32_t   575249432       
ackno   u32_t   1732313088      
_hdrlen_rsvd_flags      u16_t   6224    
wnd     u16_t   1017    
chksum  u16_t   23595   
urgp    u16_t   0       

tcphdr error (mb):
src     u16_t   10450   
dest    u16_t   62977   
seqno   u32_t   601707332       
ackno   u32_t   929038336       
_hdrlen_rsvd_flags      u16_t   6224    
wnd     u16_t   62709   
chksum  u16_t   10063   
urgp    u16_t   0       

tcphdr error (web):
src     u16_t   4307    
dest    u16_t   20480   
seqno   u32_t   1664538112      
ackno   u32_t   2808348672      
_hdrlen_rsvd_flags      u16_t   4176    
wnd     u16_t   61690   
chksum  u16_t   42544   
urgp    u16_t   0       

tcphdr error (web):
src     u16_t   31443   
dest    u16_t   20480   
seqno   u32_t   518157564       
ackno   u32_t   2617311488      
_hdrlen_rsvd_flags      u16_t   4176    
wnd     u16_t   61690   
chksum  u16_t   60395   
urgp    u16_t   0       

tcphdr correct (mb):
src     u16_t   53789   
dest    u16_t   502     
seqno   u32_t   3167854155      
ackno   u32_t   62947   
_hdrlen_rsvd_flags      u16_t   6224    
wnd     u16_t   63921   
chksum  u16_t   18806   
urgp    u16_t   0       



--
Sent from: http://lwip.100.n7.nabble.com/lwip-users-f3.html

_______________________________________________
lwip-users mailing list
lwip-users@nongnu.org
https://lists.nongnu.org/mailman/listinfo/lwip-users

Reply via email to