On Thu, May 22, 2014 at 12:08 AM, PCMan <pcman...@gmail.com> wrote: > Hello, > I've started to work on the Qt5 migration. > Since Julien has did some work on it, I'll base on his work. > However, there are two remaining problems. Luis, your comments are wanted.
Some history first: I ported libqtxdg to Qt5 before razor-qt and lxde merged. Sokoloff then took my work and enhanced it. Sokoloff did a very good job. Don't ask me why but that work never got merged back to libqtxdg :( This discussion is about the headers naming and libraries naming. > 1. qtxdg header names & library names > Julien changed the header file naming in his branch. > https://github.com/gilir/libqtxdg-qt5 > For Qt4, headers are installed to /usr/include/qt4/QtXdg. > For Qt5, installed to /usr/include/qt5/QtXdg > So for both Qt4 and Qt5, all headers can simply be included like this: > #include <QtXdg/XdgDesktopFile> > Then we don't need something like this. > #ifdef QT_VERSION_CHECK >= 0x050000 > #include <qt5xdg/XdgDesktopFile> > #lse > #include <qtxdg/XdgDesktopFile> > #endif > Is this OK for you, Luis? > Well, I personally think that it's better to use > /usr/include/qtxdg-qt4/ not /usr/include/qt4. Installing to .../include/qt4 or ..../include/qt5 it's not the way to go IMO. Those directories are for Qt itself. It's a non written law. #include <XdgDesktopFile> works, already, for Qt4 and Qt5. It may have name clashes in the future, it's a fact. I want to break existing code as little as possible. So I don't want to break #include <XdgDesktopFile>. It's a valid portable (Qt4/5) way to include the header. #include <qtxdg/xdgdesktopfile.h> is another story. I left it in place to give time to people to update it. Eventually, with time, the Qt4 version will enter maintenance mode. So IMO, the Qt4 and Qt5 headers should be installed in different locations, as they are now. So my proposal is: 1) maintaining #include <XdgDesktopFile> working 2) adding #include <QtXdg/DesktopFile> In the mean time implemented it. It's here: https://github.com/luis-pereira/libqtxdg/tree/header-namespace Comments are welcome > Besides, Julien changed the library names to libqtxdg-qt(4|5) based on > qt version. The breaking only when needed applies IMO here also. Right now the situation is: - for the Qt4 version the library name is libqtxdg. Why change it ? Why break other projects ? There's no gain in it IMO. - for the Qt5 version the library name is libQt5Xdg. It follows Qt5 naming itself. IMO it;s a good name. I think there is here a mix of library name and package name. The package name can have one name and the library a different name. That's actually what happens most of the time. Example in Ubuntu library name: libQtCore package name: libqt4-core > 2. In liblxqt, lib name is changed to liblxqt-qt(4|5). If there are no > objections, I intend to use them. liblxqt is different because it's an "internal" library. Regards, -- Luís Pereira ------------------------------------------------------------------------------ "Accelerate Dev Cycles with Automated Cross-Browser Testing - For FREE Instantly run your Selenium tests across 300+ browser/OS combos. Get unparalleled scalability from the best Selenium testing platform available Simple to use. Nothing to install. Get started now for free." http://p.sf.net/sfu/SauceLabs _______________________________________________ Lxde-list mailing list Lxde-list@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/lxde-list