On 18.10.2016 18:43, Kornel Benko wrote:
Am Dienstag, 18. Oktober 2016 um 18:30:22, schrieb racoon <xraco...@gmx.de>
On 18.10.2016 10:13, Kornel Benko wrote:
Am Dienstag, 18. Oktober 2016 um 09:58:14, schrieb Jean-Marc Lasgouttes 
<lasgout...@lyx.org>
Le 18/10/2016 à 09:55, racoon a écrit :



On 18.10.2016 09:46, Jean-Marc Lasgouttes wrote:
Le 15/10/2016 à 19:53, racoon a écrit :
Yes, I think so.

Does compiling in normal mode help to recover the original speed?

Could you remind me how to compile in non-debug mode? Is that a setting
in CMAKE that I have to uncheck or so?

Kornel? Uwe?

(I am an autoconf guy)

JMarc

Maybe this could help:
        -DLYX_DEBUG=OFF -DLYX_RELEASE=ON

        Kornel

I have disabled LYX_DEBUG and LYX_RELEASE in cmake gui, generated and
reconfigurated. It seems to be still the same (slow).

Why disabling LYX_RELEASE?

Sorry, I just wrote it wrongly but set it correctly. LYX_RELEASE is enabled.


Maybe the VS output is helpful?

1>------ Build started: Project: lyx_version, Configuration: Debug Win32
------
1>  -- Git-hash = 120e84a
1>  -- Created C:/LyX/LyX2.3.0-build/lyx_date.tmp
1>  -- Created C:/LyX/LyX2.3.0-build/lyx_commit_hash.tmp
2>------ Build started: Project: INSTALL, Configuration: Debug Win32 ------
2>  -- Install configuration: "Debug"

No wonder, because LYX_RELEASE is disabled. Should have been
         -- Install configuration: "Release"

See above. Also tried another run of cmake but it didn't help. Is there something else I have to uncheck? Maybe within VS?

2>  -- Up-to-date: C:/LyX/LyX2.3.0-build/LYX_INSTALLED/bin/LyX.exe
2>  -- Up-to-date: C:/LyX/LyX2.3.0-build/LYX_INSTALLED/bin/tex2lyx.exe
2>  -- Up-to-date:
C:/LyX/LyX2.3.0-build/LYX_INSTALLED/Resources/lyx2lyx/lyx2lyx_version.py
2>  -- Up-to-date:
C:/LyX/LyX2.3.0-build/LYX_INSTALLED/Resources/lyx2lyx/lyx2lyx
========== Build: 2 succeeded, 0 failed, 23 up-to-date, 0 skipped ==========

Daniel

Btw, I use Qt5.7 on linux and don't feel any slowness.

        Kornel


Reply via email to