Am Dienstag, 12. Juni 2018 14:41:01 CEST schrieb Kornel Benko <kor...@lyx.org>:
> Am Dienstag, 12. Juni 2018 14:17:02 CEST schrieb Jean-Pierre Chrétien 
> <jeanpierre.chret...@free.fr>:
> > Le 12/06/2018 à 12:13, Kornel Benko a écrit :
> > > We are requesting aastex6.cls, but this is not provided by TL18.
> > > 
> > > Instead there exists aastex62.cls (version 6.2 instead of version 6.0).
> > > 
> > > Looks like we need some general solution to be able to use existing .cls 
> > > file :(
> > 
> > When the new class has a different name, we can manage as described in 
> > section 
> > 3.3 of Development.lyx.
> > 
> > We should review of course the layout, there are some improvements in the 
> > new 
> > class. The big change in the aastex class came with aastex6.cls however, I 
> > do 
> > not know if we rewrote completely the template at the time. In addition, I 
> > guess 
> > they started a numeric naming of classes, there existed an aastex61.cls 
> > file 
> > between Oct. 2018 and Jan. 2018, which apparently did not get in TeXLive 
> > 2017.
> > 
> > We could move templates/aastex6.lyx to templates/obsolete/.
> 
> I do not favor this. Because TL18 may come much later for most distros.
> 
> > Would this be enough? Maybe obsolete is not correct there (used for classes 
> > which are not in use anymore). What about a 'deprecated' directory ?
> > 
> 
> I had something like regular expression in mind. For instance in 
> aastex6.layout
> we could have
>       
> #\DeclareLaTeXClass[aastex6[12]?,amssymb.sty,latexsym.sty,natbib.sty,verbatim.sty]{American
>  Astronomical Society (AASTeX v. 6)}
> 

Hm, simply changing 'aastex6' to 'aastex62' does not help, because now we have 
the next error:
        ! Class revtex4-1 Error: \and is not supported.

        Kornel




Attachment: signature.asc
Description: This is a digitally signed message part.

Reply via email to