The problem has been corrected!  Apparently you now have to declare the 
beginning and end of the frontmatter \begin{frontmatter}{} etc.  I have no idea 
why this is now the case as it always worked fine before without.  Thanks 
everyone for the timely help!
> On Dec 1, 2014, at 10:40 PM, Stephan Witt <> wrote:
> Am 01.12.2014 um 16:24 schrieb Andrew Crampton <>:
>> Hello Lyx Users
>> I updated lyx to before I updated to yosemite and have updated all 
>> of my LaTeX files, i.e. I have MacTeX 2014 installed and have run TeX Live 
>> Utility for updates.  I also reconfigured Lyx and have reset my computer 
>> numerous times.  I attempted to make an elsevier document fresh and have the 
>> same issue; the title and abstract page does not appear.  I exported this to 
>> a .tex file and the same problem is still present.  Other document classes 
>> still work fine, so I think it may be a problem with elsarticle and the most 
>> recent versions of OS X and Lyx.
>> Drew
> Ok, thanks for the info. Are you able to provide a small example to reproduce 
> your problem, please?
> Ideally both files, the LyX- and the TeX-file.
> Stephan
>>> On Dec 1, 2014, at 7:45 AM, Stephan Witt <> wrote:
>>> Am 01.12.2014 um 00:00 schrieb Richard Heck <>:
>>>> On Nov 30, 2014, at 10:39 PM, Richard Heck <> wrote:
>>>> On 11/30/2014 03:57 PM, Andrew Crampton wrote:
>>>>> Dear lyx users,
>>>>> I recently upgraded to lyx version and attempted to compile a lyx 
>>>>> file I made with an older version.  The pdf file is fine except that the 
>>>>> first page is missing.  This is where the abstract, title, authors etc. 
>>>>> are located.  I do a little TeX as well and could not find anything wrong 
>>>>> with the source code.  As it worked on an older version of lyx I am 
>>>>> assuming that something in the update is the issue.  I am running OS X 
>>>>> Yosemite.
>>>> Try exporting the TeX file and compiling manually. Does the problem 
>>>> persist?
>>>> Richard
>>>> On 11/30/2014 04:56 PM, Andrew Crampton wrote:
>>>>> Hi Richard,
>>>>> I exported it as a LaTeX file and compiled it in TeX Shop 3.18.  The pdf 
>>>>> again was missing the first page.  
>>>> Hi, Drew,
>>>>> I copied the header code:
>>>>> %% LyX created this file.  For more info, see
>>>>> %% Do not edit unless you really know what you are doing.
>>>>> \documentclass[10pt,a4paper,american]{elsarticle}
>>>>> \renewcommand{\ttdefault}{cmtt}
>>>>> \usepackage[T1]{fontenc}
>>>>> \usepackage[latin9]{inputenc}
>>>>> \pagestyle{headings}
>>>>> \usepackage{float}
>>>>> \usepackage{amstext}
>>>>> \usepackage{graphicx}
>>>>> \makeatletter
>>>>> %%%%%%%%%%%%%%%%%%%%%%%%%%%%%% LyX specific LaTeX commands.
>>>>> \special{papersize=\the\paperwidth,\the\paperheight}
>>>>> %%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
>>>>> %\usepackage{cite}
>>>>> \@ifundefined{showcaptionsetup}{}{%
>>>>> \PassOptionsToPackage{caption=false}{subfig}}
>>>>> \usepackage{subfig}
>>>>> \AtBeginDocument{
>>>>> \def\labelitemi{\(\triangleright\)}
>>>>> }
>>>>> \makeatother
>>>>> \usepackage{babel}
>>>>> \begin{document}
>>>>> Maybe it is something with the document class and the new lyx version?  
>>>> My first suggestion would be to create a simple elsarticle test file, 
>>>> outside of LyX, compile it 
>>>> manually, and see if that works. If not, then the problem is with your 
>>>> LaTeX installation and
>>>> not with LyX. I believe I saw a similar sort of problem once when 
>>>> upgrading my OS, though
>>>> that was on Linux.
>>>>> On an unrelated matter I tried opening up some older lyx files as well 
>>>>> and none of them work.  All have problems with .eps to .pdf conversion.  
>>>>> This might be another problem but I though I should let you know.  
>>> Hi Andrew,
>>> to understand what happens tell us how you did the upgrade. Did you do the 
>>> upgrade
>>> to Yosemite and to LyX at the same time? There are reports from 
>>> other users
>>> with TeX compilation problems solved by an update of there MacPorts 
>>> utilities. Are
>>> you using MacPorts too? What's the status of your LaTeX installation? Is it 
>>> updated
>>> too or not? Remember to reconfigure LyX after changing the system 
>>> environment.
>>> Stephan

Reply via email to