On 18 Oct 2016, at 21:28, Stephan Witt 
<st.w...@gmx.net<mailto:st.w...@gmx.net>> wrote:

Am 18.10.2016 um 18:45 schrieb Paola Manzini 

On 18 Oct 2016, at 16:49, Kornel Benko <kor...@lyx.org<mailto:kor...@lyx.org>> 

Am Dienstag, 18. Oktober 2016 um 15:32:08, schrieb Paola Manzini 

hi Stephan, thanks for the scissor tip, will never look at 8< the same way 
again :-)
I’ve followed all your steps, but sadly still nothing has changed - tough maybe 
I have erred somewhere? Here is what I did:
First of all I created the wrapper file, and put it in HOME\bin, which I had 
already created following your instructions.
Then I’ve run
$ cat $HOME/bin/maxima
in the terminal window, and got the two lines of the new “wrapper” file.
Then put both ~/bin and HOME/bin in the LyX path for good measure, reconfigured 
LyX, closed Lyx and relaunched it, and again, it does not work.
So I thought maybe I should also have run the last two of the three other lines 
of code to be run in the terminal. Did that, but as you can see from the 
attachment after running that command I do not get a “$” sign, but a “>” as 
terminal prompt. Maybe this is the problem?
Thanks for your patience!

No problem. Simply type the 2 lines, cat is awaiting input.
To end the input you have to enter EOF, probably it is control+D.


thanks Kornel (and Stephan), but now the result is that the maxima wrapper has 
been overwritten by empty lines!
So just to recap what I’ve done:
1. created the wrapper file, called it maxima, put it in HOME/bin, and checked 
it is there with the correct content by running the command “$ cat 
$HOME/bin/maxima” (no quotes) in the terminal window; I can also see the file 
in finder
2. run the three commands in the terminal window, where after the second line I 
had to use ctrl D to signal end of file
as a result, the “maxima” file has become an empty file (indeed, running “$ cat 
$HOME/bin/maxima” in the terminal window returns empty lines.
No change in behaviour in Lyx. If it helps, I have also Maple and Mathematica 
installed on my machine, but no luck invoking them from LyX either.
screenshot of terminal window is attached in case it is of any help.
Above all, thanks for taking the time with this.
<Screen Shot 2016-10-18 at 17.44.15.png>

Hi Paola,

I tried to be as verbose as I can - but it was too terse, sorry.

Two points:
1. The dollar sign in front of my command line text shouldn’t be typed.
It’s usual to mark text input as terminal input.
2. The EOF marker is an arbitrary text and should have been typed as given.

I’ll attach a screen shot of a my terminal session to prepared the wrapper 

Finally the correct PATH extension in LyX settings is important.
Either it should be „$HOME/bin“ or „~/bin“ - having both does not harm
but it slightly reduces the startup speed of every external script.


<Bildschirmfoto 2016-10-18 um 22.17.21.png>

Dear Stephan,

thanks so much for the time you are taking on this, and apologies for being 
slow! I have tried following exactly what you did, but there seems to be a 
problem when I get to “which maxima” - I get an empty line. On the other hand, 

cat $HOME/bin/maxima
does return the contents of the file, and I do see a newly created maxima file 
in the “bin” folder (in finder) - maybe my system is missing some other 

Again, many thanks,


Reply via email to