Hi Jürgen, hi Philip,

in openSUSE Leap 42.2 I've tried countless times to produce PDF outputs with both, classicthesis-Lyx-v4.2_biblatex-biber and classicthesis-Lyx-v4.2_biblatex-bibtex8 but always ended up in endless loops.

After two weeks I tried openSUSE Leap 42.2 once more last night (out of desperation and frustration) and to my surprise both, biblatex-biber and biblatex-bibtex8, generated perfect PDF outputs - and very quickly.

In Documents > Settings > Bibliography > Bibliography Generation > Processor it offers

 * Default
 * biber !!!!!
 * bibtex
 * bibtex8

while in Mageia6 'biber' is still missing.
So, looks like one must wait till "biber" is made available in Mageia6 and working.

Thanks a lot for your continuous support, and cheers!


Am 29.07.2017 um 18:06 schrieb Michael Berger:


I did as you told me

- I installed all the groups of texlive packages Mageia is offering but I don't know for certain whether or not "biber" is installed; I find no way to look for a single package called texlive-biber or texlive-biblatex

- I did reconfigure several times

- I cannot set the Bibliography Processor to "biber" in Documents Settings because it is not a choice - all I see is: Default, bibtex, bibtex8. And in Tools > Preferences > Output > LaTeX > Processor I see only Custom, bibtex, bibtex8.

I hope I am not too stupid and sorry for bothering you!


Am 29.07.2017 um 13:51 schrieb Jürgen Spitzmüller:
Am 29.07.2017 10:42 vorm. schrieb "Michael Berger" <id...@online.de <mailto:id...@online.de>>:

    BibTeX error: I found no \bibstyle command-----while reading file

    If I force the PDf output everything looks fine except that there
    is no bibliography shown

    LogType LaTeX shows some warnings but no errors
    LogType BibTex shows some warnings but no errors

Obviously, you need to install biber, then reconfigure LyX and repeate the procedure I described.

    I have Mageia6, KDE

Look for a package called texlive-biber or texlive-biblatex.

    Document Settings Module: Linguistics

    Funny enough, classicthesis-LyX-v4.2_biblatex_bibtex8 outputs a
    perfect PDF, even if I completely remove/replace the LaTeX Preamble.

That's not funny, it is expected, if bibtex8 is installed.


    Thanks and Best,

Reply via email to