On 08/12/2017 05:25 PM, Rich Shepard wrote:
On Sat, 12 Aug 2017, Paul A Rubin wrote:

Curious. Your setup must be a tad nonstandard.


  Could be ... because I am.
Ain't we all!

I tested it at my end (using " pdf2") and it worked. In the list of file
formats (under preferences) on both my machines, pdf2 is "shorthand" for
"PDF (pdflatex)". That's a LyX default, not something I screwed with.

Hmmm-m-m. Under Tools -> Preferences -> File Handling -> File formats for default output formats with TeX fonts PDF (pdflatex), with non-TeX fonts DVI
(LuaTeX). The Shortcut text entry widget is empty.

  I use the T1 TeX font encoding; the default body text typeface is
Same one mine, but that's not the key bit. And, in hindsight, it's possible I gave you the way to export to the wrong format.

Under Tools > Preferences > File Handling > File formats, click on the Format select box at the top and scroll to "LaTeX (pdflatex)". I suspect that under "Short name" you have "pdflatex", as I do. Now switch the select box to "PDF (pdflatex)", and I suspect the short name is now "pdf2". At least it is on my systems.

So I gave you the shortcut to export the buffer as a PDF file, compiled using pdflatex, which might not be what you had in mind. What worked for you should be producing a LaTeX source file compatible with pdflatex. If that's what you want, dandy. The expression of confusion by LyX when you used "pdf2" suggests that maybe it doesn't know how to compile to PDF using pdflatex (converter not specified, didn't find pdflatex on your system, finds pdflatex morally objectionable, thinks it's a Russian plot/Chinese hoax/SNL skit, ...).


Reply via email to