On 2019Aug16, at 05:28, Richard Kimberly Heck <rikih...@lyx.org> wrote:
> On 8/15/19 5:00 PM, Matthias Görlach wrote:
>> Hi,
>> after running and using Lyx for maybe 10 years, I finally tried to upgrade 
>> from v 2.2.4 to 2.3.2 and 2.3.3.
>> This resulted in unusability or continuously repeated error messages 
>> relating to "missing document classes", something about "missing library" 
>> and finally to "LyX will only have minimal functionality because no text 
>> classes have been found. You can either try to configure LyX normally, try 
>> to reconfigure without checking your LaTeX installation, or continue." 
>> <https://www.google.com/search?client=firefox-b-e&q=LyX+will+only+have+minimal+functionality+because+no+text+classes+have+been+found.+You+can+either+try+to+configure+LyX+normally,+try+to+reconfigure+without+checking+your+LaTeX+installation,+or+continue.&spell=1&sa=X&ved=0ahUKEwiEq5Ti34XkAhVLKuwKHRNmDN4QBQgxKAA>
>> I tried a lot - to no avail - incl newsgroups, Wiki etc etc
>> Reconfigure didnt do a thing - neither a complete new install of the recent 
>> MacTEX suite, reinstall of Lyx etc etc. Other TEX distribs (e.g. mac 
>> texmaker) worked flawlessly.
>> My System MacOS X, 10.12.6 Sierra incl latest patches on a MacBook Pro 
>> (MacBookPro9,2).
>> ONLY completely removing any traces of Lyx and reinstalling Lyx 2.2.4 solved 
>> the problem - its running fine.
>> Accd to the Lyx web site, the latest release of Lyx (2.3.3) should be 
>> running fine on my system - so what is the issue???
>> Any hints/help available??
> There are some OSX folks around, so I'm updating the subject and cc'ing our 
> Mac guru. We've not had any other reports of this problem, so we know 2.3.x 
> will run on OSX. Not that that's any help to you!
> Is it possible to install 2.3.x alongside 2.2.4? Possibly as a different 
> user? If so, it'd be interesting to see the output of the reconfiguration 
> script. That might give us some hint what's going wrong.
> Riki
I can’t help much. 2.3.3 is running fine here (High Sierra) and I often have 
multiple versions alongside when I upgrade.
The only thing I can think of that isn’t mentioned is to perform a sudo texhash 
from the Terminal.


Reply via email to