Am 12.02.2021 um 10:52 schrieb
>> On Feb 10, 2021, at 6:06 AM, Stephan Witt <> wrote:
>> Am 10.02.2021 um 11:34 schrieb
>>>> On Feb 9, 2021, at 5:16 AM, Stephan Witt <> wrote:
>>>> Am 09.02.2021 um 13:01 schrieb
>>>>> I’m trying to learn version control (SVN) with LyX on macOS. I have a 
>>>>> little past experience with SVn in another context and I’m in Chapter 2 
>>>>> of the book at as a refresher. I am the only person 
>>>>> who will access the repository which is on my own computer.
>>>>> I have set up new repository and imported three files, a LyX document and 
>>>>> two graphics files. (I am using a nice GUI app on the Mac). I can check 
>>>>> out the LyX document, edit it, and commit. But what I can’t figure out is 
>>>>> what is the LyX File -> Version Control -> Register item for? I think it 
>>>>> wants to add the current LyX file, which is assumed to be not under 
>>>>> version control, to the repository. But _what_ repository? I made a 
>>>>> second LyX file named Registering.lyx and typed “Registering a document” 
>>>>> into the dialog box. Then I get this message:
>>>>> Some problem occurred while running the command:
>>>>> 'ci -q -u -i -t-"Registering a document" "Registering.lyx"'.
>>>>> I think I am somehow am missing “Step 0” in setting things up.
>>>>> Thanks as always for any hints.
>>>> The problem with the "Register Item“ menu item is its missing cleverness. 
>>>> It assumes the RCS version control system. That’s why it is unusable with 
>>>> all other systems like SVN and GIT.
>>>> You have to register (add) it to your repository manually or with the help 
>>>> of your GUI. Later you’re able to work with the LyX version control 
>>>> features.
>>>> Stephan
>>> Thanks, but still not working.
>>> I create a new repository on my computer, then import or add a LyX 
>>> document. The new doc appears as expected in the repository. I checkout the 
>>> file into a working copy and edit with LyX, then commit the changes, make 
>>> comparisons, etc. with my SVN client. In other words, I believe that I can 
>>> manage things with my SVN client as expected. 
>>> However, I cannot get the built-in LyX functionality to work. When the 
>>> working copy of the LyX file is open, none of the expected File -> Version 
>>> Control -> menu items appear, only Register…. Also, most of the icons in 
>>> the Version Control Toolbar become active—only Register and Insert Version 
>>> Info do anything, the latter inserting “No version control.”
>>> The working copy that I checked out is apparently known as related to SVN 
>>> because it has the .svn directory. Also (this is an update from my original 
>>> post) when attempting the Regiser… action, I get a message
>>> Some problem occurred while running the command:
>>> 'svn add -q "Learning SVN in LyX.lyx”'.
>>> So LyX recognizes somehow the presence of SVN but is trying to perform an 
>>> add operation on a file that is already in the repository.
>>> Clearly I am missing a basic step.
>>> Jerry
>> Ok, it would be better if I verify my statements sometimes.
>> I’ve checked it myself now and it works for me. See the log below:
>> 13:59:54.564: Öffne Dokument ~/tmp/playground/Shortcuts-test2.lyx...
>> 13:59:54.679: svn info "Shortcuts-test2.lyx"
>> 13:59:54.693: svn: warning: W155010: The node 
>> '/Users/stephan/tmp/playground/Shortcuts-test2.lyx' was not found.
>> 13:59:54.693: 
>> 13:59:54.694: svn: E200009: Could not display info for all targets because 
>> some targets don't exist
>> 13:59:54.705: Dokument ~/tmp/playground/Shortcuts-test2.lyx ist geöffnet.
>> 13:59:54.706: (file-open: ⌃O)support/Systemcall.cpp (276): Systemcall: 'svn 
>> info "Shortcuts-test2.lyx"' finished with exit code 1
>> 14:00:07.860: svn proplist "Shortcuts-test2.lyx"
>> 14:00:07.877: svn: warning: W200005: 
>> '/Users/stephan/tmp/playground/Shortcuts-test2.lyx' is not under version 
>> control
>> 14:00:07.877: svn: E200009: Could not display properties of all targets 
>> because some targets are not versioned
>> 14:00:07.878: svn: E200009: Illegal target for the requested operation
>> support/Systemcall.cpp (276): Systemcall: 'svn proplist 
>> "Shortcuts-test2.lyx"' finished with exit code 1
>> 14:00:16.886: svn add -q "Shortcuts-test2.lyx"
>> 14:00:16.984: svn info "Shortcuts-test2.lyx"
>> 14:00:17.007: svn proplist "Shortcuts-test2.lyx"
>> 14:00:17.024: Dokument ~/tmp/playground/Shortcuts-test2.lyx neu geladen.
>> Conclusion:
>> 1. The working environment is LyX- and svn binary in path (verify it 
>> in terminal).
>> 2. You may check and possibly update your LyX app.
>> 3. You may activate the status message pane and redo the register VC command.
>> Stephan
> 1. and 2. I upgraded LyX from 2.3.2 to Legacy. (Thanks for Legacy, 
> devs!) svn binary is in path. Same behavior.
> 3. Message pane reports " svn: This client is too old to work with working 
> copy '.'; please get a newer Subversion client”
> I’ll need to think/experiment some with this. The GUI client uses its own 
> version(s) of svn: I have tried 1.7.19 and 1.8.10 from the GUI. However my 
> command line version is 1.9.4. So I guess I have to somehow get these 
> versions coordinated. But the error message “please get a newer Subversion 
> client” kind of doesn’t make sense since surely LyX is seeing the 1.9.4 
> version.

Yes, that’s strange. You may lookup the locations of your different svn 
binaries and prepend them in LyX’s PATH configuration to try something.

> The Additional Features manual states that LyX has been tested with 1.5, 1.6, 
> 1.7. and 1.8. It is silent about 1.9.

That’s because of nobody tried it.


> Jerry
> -- 
> lyx-users mailing list

lyx-users mailing list

Reply via email to