Hi there, I've been working for some months now with lyx, in my office,
on a gentoo-gnome environment, and it's just so fun to work on it, that
I decided to make also my school works on it.
My problem is, that during the weekends I only have acces to an iBook
with MacOsX version 10.3.5, and I tried to install lyx with fink, It was
all ok, I even got lyx up and running, but when tried to open a
document, it displays the folowing errors.

Textclass error
The document uses an unknown textclass article --substituting default.


Textclass error
The document uses a missing TeX class article LyX will not be able to
produce output.

I installed all the Tex, tetex, and latex, possible dependencies, I also
uninstalled lyx and tried the qt version, and it still shows that error.

Also, when I go to the layout/Document_Settings screen, on Document
Class it sais Unavailable:article. And on view, there isn't displayed
the usual DVI, HTML, PDF, etc. options.

On the X11-term, even if I try to open a book format document, I get a
list of:
Layout 'Chapter' does not exist in textclass 'article'.
Trying to use default layout instead.

I haven't seen on the lists this problem yet, and I tried to search on
the manuals but right now havo no clues. Can anyone point me to the
right documentation?

I thank your help
best regards
Emiliano Ricci

Reply via email to