I have a problem at spell-checking in Lyx-1.4.3 (qt front-end), that seems 
related with the character encoding. Aspell continues using iso-8859-x, the 
operating system, Mandriva2007, uses utf-8, and Lyx... well I am not sure. On 
the other hand I use KDE, and the default locale is pt_PT.UTF-8

At spell-checking from within LyX, with Portuguese or Spanish,  the list of  
suggestions of Aspell is full of strange characters, something like:

But I can use Aspell within other programs without problems, for example 
Kwrite or KMail.

Following the wiki:  http://wiki.lyx.org/Tips/SettingLANG,
I tried to change the LANG from pt_PT.UTF-8 to pt_PT or to pt_PT.ISO-8859-1
but without success. If I run,  for example:

        LANG=fr_FR lyx

the menus do not appear in french, as expected, but remain in Portuguese.

This did not surprise me, because is the same behaviour that in Mandriva2006, 

Before to upgrade to Mandriva2007 I was using Mandriva2006 with LyX-1.3.3. 
In this cases I had a similar problem,  that WAS SOLVED setting the variable 

So running    
        KDE_LANG=fr_FR lyx

would launch LyX with french menus, and made Aspell works correctly.  
(I used KDE_LANG=pt lyx)

I have made some test with KDE_LANG and LANG and the results are mixed:

1) Some programs obey the KDE_LANG setting:
    Kde programs, as expected, plus Amarok and K3b

2) Scribus obeys the LANG setting, 

3) Other programs do not obey neither the LANG nor the KDE_LANG setting:
     LyX, Helixplay, Inkscape, Gimp

Any idea how to solve the problem, i.e. how to spell-check non-English texts 
within LyX?


Reply via email to