So, now some interim report about me trying to compile lyx
on 10.6.

To sum up, I think I messed things up with QT.

First, I didn't find QT 4.3.3 on the QT/Nokia page, the
links to the "archives" there aim to quite empty ftp-servers
with QT3-versions on it.

So I downloaded the actual QT4.5.2 for Mac binary installer
and installed it. That was not a good thing to do.

Later I found the QT4.3.3 source-package by googling
around. I haven't installed this yet.

I tried to compile the lyx 1.6branch which I got via svn
(nice thing: 10.6 has svn already included now) following
the instructions of the INSTALLMACOSX file.

Well, configuring always fails as it cannot find the

I looked up where the 4.5.2 binary installs files:

Qt Designer, Qt Linguist: /Developer/Applications/Qt

Qt Documentation: /Developer/Documentation/Qt

Qt Examples: /Developer/Examples/Qt

Qt Plugins: /Developer/Applications/Qt/Plugins

Qt Frameworks: /Library/Frameworks

Qt Libraries: /usr/lib

qmake, moc, uic, etc.: /Developer/Tools/Qt (symlink to
/usr/bin, so they are really there)

Uninstall script: /Developer/Tools/

I tried it with /usr/bin and /Developer/Tools/QT as
Qt-path-option of the configure command: Same result qt
directory not found.

So I thought about going one step back by removing 4.5.2
first and then compile 4.3.3, but:

The script runs fine and exits without error,
but it didn't remove anything.

As this does not work, I think I have to figure out every
single file that the binary installer placed onto my
harddrive. How nice that it installs to /usr/lib and
/usr/bin by default! *grml*

I stopped here and didn't do anything, before making all
that mess bigger

Reply via email to