On 01/07/2010 09:23 AM, weremoose wrote:

I am a mac user (currently on 10.6.2) and I decided to use LyX to write my
thesis as it looked very promising. So I have LyX 1.6.5 installed and
started testing it, it's very convenient and gets me nice looking text even
with my drafts. Everything good so far. I found that I can use Zotero for my
references, installed it along with lyz, everything works fine now and my
citations are pushed to LyX.

The thing is, there must be some kind of bug and no matter how much I tried
I can't get it to work. I've been trying for more than a week and I feel
quite stupid... I am inserting my BibTex generated bibliography at the end
of my document, I select my database file, I add citations, fine, but the
citations just don't want to show up in my pdf file. I tried changing the
document style, nothing (I am using book-komma-script) I tried the
bibliography preferences with all the citation options, I tried latex
export, I tried dvi preview, I tried pdf preview, all I get is instead of my
references a questionmark [?] or ? depending on the citation preferences and
no bibliography in the end. I tried to use different citation styles as
well, it is still not working.

One common reason for this is that the BibTeX file has the wrong sort of encoding, in particular, that you are somewhere using Unicode characters that are confusing the BibTeX processor. This is especially likely if you have tried exporting to LaTeX and running everything manually. Indeed, that is the best way to debug this kind of problem: Export to LaTeX; run the LaTeX sequence manually from a terminal ("latex myfile"; then "bibtex myfile"; then "latex myfile"; then "latex myfile" again, if necessary) and watch for error messages. You will see undefined citations the first latex run; this is normal and is why you need to run bibtex. It's on the bibtex run that you'll see what's causing the problem. As I said, quite possibly encoding issues.

If things DO work properly when you run things manually, then the problem is elsewhere. It could be that LyX isn't finding your bibliography file; it could be that lyz (which is very know) is doing something wrong.


Reply via email to