Dear Lyx Users,

I need to include lots of .eps graphics files in my Lyx document.
These .eps files are produced by GNUplot using the epslatex terminal
driver which produces a .tex files and a .eps file for each graph.

In Lyx 2.0.0, including my graphs was as simple as putting

\input{graph.tex}

in ERT.  Behind the scenes, this would invoke an instance of epstopdf
to convert each .eps file to a .pdf file.  This worked fine in Lyx
2.0.0.

This no longer works in Lyx 2.0.1.  The problem is that epstopdf is
being run in a temp directory (e.g.
"/tmp/lyx_tmpdir.T13883/lyx_tmpbuf2") but epstopdf is not given a way
to locate the .eps file. The Lyx log file reports that epstopdf is
being called like this:

runsystem(epstopdf --outfile=graph-eps-converted-to.pdf graph.eps)

As you can see, epstopdf has no way of finding where "graph.eps" lives.

I have tried setting "\graphicspath{{/path/to/eps/file/}}" in my
document preamble but this did nothing.  I tried providing my graphics
directory in Lyx's "Working directory", "Temporary directory", "PATH"
and "TEXINPUTS prefix" Paths fields but this did not help.

The only "fix" I have found so far is to open each .tex file (e.g.
graph.tex) in a text editor and manually edit the
"\put(0,0){\includegraphics[width=\unitlength]{graph.eps}}" line to
include the absolute path of the .eps file.  This is not a
satisfactory solution for many reasons.

I'd really love it if someone could suggest a solution!

Many thanks,
Jack

Reply via email to